Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 07, 2026 - 04:00 EST
Scheduled
Service is expected to be temporarily down at this time due to a network infrastructure upgrade.
Impacted locations/regions: Provenance Apartments and Discovery Park Homes, 47906 Date/Time: 01-07-2026 - 04:00am-05:00am Outage Duration: Up to 20 minutes
Posted Jan 02, 2026 - 15:33 EST
This scheduled maintenance affected: Haywire Internet Service.