A fix has been implemented and we are monitoring the results.
Posted Dec 18, 2025 - 14:26 EST
Identified
A temporary backup connection has been put in place which should improve network performance. Estimated resolution time for primary connection is 2:00 PM.
Posted Dec 18, 2025 - 12:03 EST
Investigating
We are currently investigating a significant service performance decrease affecting units at Broad Ripple Townhomes.