St. James Apartments - Slow Speeds

Incident Report for Haywire

Resolved

The issue has been resolved.
Posted Feb 01, 2026 - 08:33 EST

Investigating

We are investigating reported slow speeds at the St. James apartments.
Posted Feb 01, 2026 - 07:54 EST