Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 04, 2025 - 00:00 EST
Scheduled
Emergency maintenance is scheduled to be performed on core fiber infrastructure, impacting THIRD apartments on the morning of November 4, 2025. The total expected duration of the disruption is anticipated to be up to 5 hours.
Date/Time: 2025-11-04 - between 12:00am - 05:00am Duration: 5 hours Impacted region/location: Bloomington, IN
Posted Nov 03, 2025 - 10:58 EST
This scheduled maintenance affected: Haywire Internet Service.