St James Apartments - Intermittent service disruptions

Incident Report for Haywire

Resolved

Our team has resolved this issue.
Posted Nov 04, 2025 - 09:36 EST

Investigating

We are currently investigating degraded service performance at the St James apartments and are working on implementing a fix.
Posted Nov 03, 2025 - 16:29 EST
This incident affected: Haywire Internet Service.