Indiana Flats Outage

Incident Report for Haywire

Resolved

This incident has been resolved.
Posted Jul 12, 2025 - 18:05 EDT

Investigating

We are currently investigating an issue impacting building 735 at Indiana Flats.
Posted Jul 12, 2025 - 16:38 EDT