Indiana Flats - Partial Outage

Incident Report for Haywire

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 16:57 EDT

Investigating

We are currently investigating a partial outage affecting service at Indiana Flats.
Posted Oct 24, 2025 - 12:04 EDT
This incident affected: Haywire Internet Service.