St James Partial Outage - Power Related

Incident Report for Haywire

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 21:41 EDT

Investigating

We are investigating a partial service outage at St James apartments related to recent power events in the area. Estimated time of service restoration is 8pm.
Posted Sep 11, 2025 - 18:55 EDT