Downtown Indianapolis Internet Outage
Incident Report for
Haywire
Resolved
This incident has been resolved.
Posted
Mar
22
,
2025
-
13:51
EDT
Identified
We have identified a fault in a hardware device and are working to restore service.
Posted
Mar
22
,
2025
-
13:36
EDT
Investigating
We are investigating an outage impacting our downtown Indianapolis locations
Posted
Mar
22
,
2025
-
13:19
EDT
×
Subscribe to Incident
Subscribe to updates for
Downtown Indianapolis Internet Outage
via . You'll receive .