Union Grand Junction Degraded Service

Incident Report for Haywire

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 07:43 EDT

Update

We are continuing to investigate this issue.
Posted Jul 30, 2026 - 07:43 EDT

Investigating

We are currently experiencing degraded services at Union Grand Junction. We are monitoring the status of the issue, and services are restored quickly. You may experience intermittent service issues during this time.
Posted Jul 30, 2026 - 07:33 EDT
This incident affected: Haywire Internet Service.